Game Stuck - not sure where to post

This game has been a bit glitchy, and now it seems I'm completely stuck. I just
had a conversation in the basement with Mr. Reed.
At the end of the conversation it is indicated I should pick up the
mustache cup
but I'm unable to grab it—the magnifying glass doesn't even highlight when i hover over it. I tried saving the game right after the conversation and loading it there, after doing that the magnifying glass did highlight when hovering over the object, but as soon as I clicked it it completely crashed the game. Tried it three times with the same result. Any known fixes for this? 


  • Hi @SleuthFive!

    This issue should be resolved in the latest update, are you running version 1.0.9?

    You can check what version you are using, by either going to the last page of the Help book and looking in the lower right corner of the page, or by looking in the title bar of the launcher window!

    If you aren't running 1.0.9 and the launcher is not prompting you that an update is available, you should go to your account page and download the latest version.

    If you are running 1.0.9 then please let us know.

    I hope this helps, and let us know if you need anything else!

Sign In or Register to comment.