Mannequins not loading after entering room

About half of my mannequins for the halloween ride contest don't load when entering each of the rooms they are in regardless how long I wait, but they do load just fine after I reenter the same room,. I've tried changing out the mannequins, and redoing the clothing however I still have the issue.. I don't want someone to see a blue blob when riding my ride.. I also don't want to remove the mannequins as they are a part of my ride. Does anyone have any suggestions on how to solve this issue? Thanks!!
dazzlej signature02


  • I know someone solved this issue by putting a mannequin in the previous room with the same clothing on it, but hiding it, so that it loaded early before going to the next room.

    You could try that!
    Sheep_Trimmed blossomflower Sheep_Trimmed  - Just ask if you'd like me to make you a GIF or Sig Bar!
  • I'll try that to see if it will help when riding my ride.. however when I go straight into the room it also happens as well.. the weird thing is that there are times where they load just fine when first entering the room.. yet other times not.. 

    Now however when I go into the room I still get the blue blob sometimes but when I add something into the room the blue blob disappears and the clothing show up. This may be a long shot but does EA have anything to do with it not loading? Is it my computer? or is it something else entirely? I just want to make sure everyone sees my room how I want it without the blue blobs interfering with the atmosphere of the room.
    dazzlej signature02
Sign In or Register to comment.